ImportElements Method


IFCHybrid Import Import Elements Method

Imports IFC Elements using AnyCAD.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> ImportElements(
	Document doc,
	string file
)

Parameters

doc Document
Document to receive elements from the IFC file import.
file String
Full path of the file to import.

Return Value

IList ElementId
Returns an array of ElementIds representing created elements.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also