DocumentDifference Class


DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public class DocumentDifference : IDisposable
Visual Basic
Public Class DocumentDifference _
	Implements IDisposable
Visual C++
public ref class DocumentDifference : IDisposable

Remarks

For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements. For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBDocumentDifference

See Also