Document |
DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentDifference type exposes the following members.

Name | Description | |
---|---|---|
![]() | AreDeletedElementIdsAvailable | Whether or the deleted elements were retrieved. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DocumentDifference |
![]() | GetCreatedElementIds | Created element id collection. |
![]() | GetDeletedElementIds | Deleted element id collection. For non-worksharing models, this will always be an empty collection. |
![]() | GetModifiedElementIds | Modified element id collection. |

For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements. For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.