DocumentDifference Class


Document Difference Class

DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DocumentDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentDifference : IDisposable

The DocumentDifference type exposes the following members.

Properties
Name Description
Public property AreDeletedElementIdsAvailable Whether or the deleted elements were retrieved.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DocumentDifference
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetCreatedElementIds Created element id collection.
Public method GetDeletedElementIds Deleted element id collection. For non-worksharing models, this will always be an empty collection.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetModifiedElementIds Modified element id collection.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements. For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.
See Also