GetBoundaryFaceInfo Method


Query the spatial element boundary face information with the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo(
	Face face
)
Visual Basic
Public Function GetBoundaryFaceInfo ( _
	face As Face _
) As IList(Of SpatialElementBoundarySubface)
Visual C++
public:
IList<SpatialElementBoundarySubface^>^ GetBoundaryFaceInfo(
	Face^ face
)

Parameters

face
Type: Autodesk.Revit.DBFace
The face from the spatial element's geometry.

Return Value

Sub-faces related to the room bounding elements that define the spatial element face. Returns a null reference (Nothing in Visual Basic) if there is no corresponding boundary information with the given face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also