GetBoundaryFaceInfo Method


Spatial Element Geometry Results Get Boundary Face Info Method

Query the spatial element boundary face information with the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo(
	Face face
)

Parameters

face Face
The face from the spatial element's geometry.

Return Value

IList SpatialElementBoundarySubface
Sub-faces related to the room bounding elements that define the spatial element face. Returns if there is no corresponding boundary information with the given face.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also