Fix the direction of a segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- iSegment
- Type: SystemInt32
Index of the segment (0 to NumberOfSegments - 1).
- vecCoordX
- Type: SystemDouble
The x-coordinate of a 2D vector specifying the segment direction.
- vecCoordY
- Type: SystemDouble
The y-coordinate of a 2D vector specifying the segment direction.
Remarks
The centerline of the segment will be constrained to be parallel to the vector. The segment must have at least one constraint.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | iSegment is not between 0 and NumberOfSegments. -or- The length of the vector (vecCoordX, vecCoordY) is too close to zero. |