SetSegmentFixedDirection Method


Rebar Shape Definition By Segments Set Segment Fixed Direction Method

Fix the direction of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSegmentFixedDirection(
	int iSegment,
	double vecCoordX,
	double vecCoordY
)

Parameters

iSegment Int32
Index of the segment (0 to NumberOfSegments - 1).
vecCoordX Double
The x-coordinate of a 2D vector specifying the segment direction.
vecCoordY Double
The y-coordinate of a 2D vector specifying the segment direction.
Exceptions
Exception Condition
ArgumentException iSegment is not between 0 and NumberOfSegments. -or- The length of the vector (vecCoordX, vecCoordY) is too close to zero.
Remarks
The centerline of the segment will be constrained to be parallel to the vector. The segment must have at least one constraint.
See Also