Rebar |
Fix the direction of a segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetSegmentFixedDirection(
int iSegment,
double vecCoordX,
double vecCoordY
)
Parameters

Exception | Condition |
---|---|
ArgumentException | iSegment is not between 0 and NumberOfSegments. -or- The length of the vector (vecCoordX, vecCoordY) is too close to zero. |

The centerline of the segment will be constrained to be parallel to the vector. The segment must have at least one constraint.