GetExportPatternInfo Method


Gets a copy of the pattern info associated to the input pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public ExportPatternInfo GetExportPatternInfo(
	ExportPatternKey exportPatternKey
)
Visual Basic
Public Function GetExportPatternInfo ( _
	exportPatternKey As ExportPatternKey _
) As ExportPatternInfo
Visual C++
public:
ExportPatternInfo^ GetExportPatternInfo(
	ExportPatternKey^ exportPatternKey
)

Parameters

exportPatternKey
Type: Autodesk.Revit.DBExportPatternKey
The export pattern Key.

Return Value

Return the patternInfo for this key.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException An entry with the given key is not present in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also