Sets the number of interior or exterior shell layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shellLayerType
- Type: Autodesk.Revit.DBShellLayerType
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
- numLayers
- Type: SystemInt32
The number of layers to be in the specified shell.
Remarks
There must be at least one core layer, i.e. one layer which is not a shell layer.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Number of shell layers is negative. -or- A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | Too many shell layers: there must be at least one core layer. |