Compound |
Sets the number of interior or exterior shell layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- shellLayerType ShellLayerType
- If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
- numLayers Int32
- The number of layers to be in the specified shell.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | Number of shell layers is negative. -or- A value passed for an enumeration argument is not a member of that enumeration |
ArgumentsInconsistentException | Too many shell layers: there must be at least one core layer. |

There must be at least one core layer, i.e. one layer which is not a shell layer.