SetNumberOfShellLayers Method


Compound Structure Set Number Of Shell Layers Method

Sets the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetNumberOfShellLayers(
	ShellLayerType shellLayerType,
	int numLayers
)

Parameters

shellLayerType ShellLayerType
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
numLayers Int32
The number of layers to be in the specified shell.
Exceptions
Exception Condition
ArgumentOutOfRangeException Number of shell layers is negative. -or- A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException Too many shell layers: Number of shell layers of this type is too large.
Remarks
Changing this value can result in Core layers becoming Shell layers. This can also result in all Core layers becoming Shell layers and there being an empty core.
See Also