IsWallCompletelyClipped Method


Determines if the input wall is completely removed by interaction with other elements within the given range.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool IsWallCompletelyClipped(
	Wall pVWall,
	ExporterIFC exporterIFC,
	IFCRange range
)
Visual Basic
Public Shared Function IsWallCompletelyClipped ( _
	pVWall As Wall, _
	exporterIFC As ExporterIFC, _
	range As IFCRange _
) As Boolean
Visual C++
public:
static bool IsWallCompletelyClipped(
	Wall^ pVWall, 
	ExporterIFC^ exporterIFC, 
	IFCRange^ range
)

Parameters

pVWall
Type: Autodesk.Revit.DBWall
The wall.
exporterIFC
Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
range
Type: Autodesk.Revit.DB.IFCIFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.

Return Value

True if the wall should be ignored within the given range.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also