Exporter |
Determines if the input wall is completely removed by interaction with other elements within the given range.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsWallCompletelyClipped(
Wall pVWall,
ExporterIFC exporterIFC,
IFCRange range
)
Parameters
- pVWall Wall
- The wall.
- exporterIFC ExporterIFC
- The exporter.
- range IFCRange
- The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.
Return Value
BooleanTrue if the wall should be ignored within the given range.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |