NewSymbolicCurve Method


Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SymbolicCurve NewSymbolicCurve(
	Curve curve,
	SketchPlane sketchPlane
)
Visual Basic
Public Function NewSymbolicCurve ( _
	curve As Curve, _
	sketchPlane As SketchPlane _
) As SymbolicCurve
Visual C++
public:
SymbolicCurve^ NewSymbolicCurve(
	Curve^ curve, 
	SketchPlane^ sketchPlane
)

Parameters

curve
Type: Autodesk.Revit.DBCurve
The geometry curve of the newly created symbolic curve.
sketchPlane
Type: Autodesk.Revit.DBSketchPlane
The sketch plane for the symbolic curve.

Return Value

The newly created symbolic curve.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when regeneration failed. Thrown when symbolic curve creation failed.

See Also