NewSymbolicCurve Method


Family Item Factory New Symbolic Curve Method

Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SymbolicCurve NewSymbolicCurve(
	Curve curve,
	SketchPlane sketchPlane
)

Parameters

curve Curve
The geometry curve of the newly created symbolic curve.
sketchPlane SketchPlane
The sketch plane for the symbolic curve.

Return Value

SymbolicCurve
The newly created symbolic curve.
Exceptions
Exception Condition
ArgumentNullException Thrown when argument is .
InvalidOperationException Thrown when regeneration failed. Thrown when symbolic curve creation failed.
See Also