Family |
Create a symbolic curve in an Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- curve Curve
- The geometry curve of the newly created symbolic curve.
- sketchPlane SketchPlane
- The sketch plane for the symbolic curve.
Return Value
SymbolicCurveThe newly created symbolic curve.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when argument is . |
InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed. |