GetBarGeometry Method


Returns the geometry for a bar at the specified index currently in the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public IList<Curve> GetBarGeometry(
	int barIndex
)
Visual Basic
Public Function GetBarGeometry ( _
	barIndex As Integer _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetBarGeometry(
	int barIndex
)

Parameters

barIndex
Type: SystemInt32
The index of the bar. Should be a number between 0 and GetNumberOfBars() - 1.

Return Value

Returns an array of curves that defines the bar at the specified index.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException barIndex is not in the range [ 0, GetNumberOfBars()-1 ].

See Also