GetBarGeometry Method


Rebar Handle Position Data Get Bar Geometry Method

Returns the geometry for a bar at the specified index currently in the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Curve> GetBarGeometry(
	int barIndex
)

Parameters

barIndex Int32
The index of the bar. Should be a number between 0 and GetNumberOfBars() - 1.

Return Value

IList Curve
Returns an array of curves that defines the bar at the specified index.
Exceptions
Exception Condition
ArgumentOutOfRangeException barIndex is not in the range [ 0, GetNumberOfBars()-1 ].
See Also