Rebar |
Returns the geometry for a bar at the specified index currently in the Rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- barIndex Int32
- The index of the bar. Should be a number between 0 and GetNumberOfBars() - 1.
Return Value
IList CurveReturns an array of curves that defines the bar at the specified index.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barIndex is not in the range [ 0, GetNumberOfBars()-1 ]. |