GetBuiltInCategoryTypeId Method


Gets the ForgeTypeId identifying the given built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static ForgeTypeId GetBuiltInCategoryTypeId(
	BuiltInCategory categoryId
)
Visual Basic
Public Shared Function GetBuiltInCategoryTypeId ( _
	categoryId As BuiltInCategory _
) As ForgeTypeId
Visual C++
public:
static ForgeTypeId^ GetBuiltInCategoryTypeId(
	BuiltInCategory categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DBBuiltInCategory
The built-in category.

Return Value

The identifier of the given built-in category.

Remarks

The given BuiltInCategory value must be valid according to Category.IsBuiltInCategoryValid(BuiltInCategory).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException categoryId is not a valid built-in category. See Category.IsBuiltInCategoryValid(BuiltInCategory).

See Also