Category Get |
Gets the ForgeTypeId identifying the given built-in category.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- categoryId BuiltInCategory
- The built-in category.
Return Value
ForgeTypeIdThe identifier of the given built-in category.

Exception | Condition |
---|---|
ArgumentException | categoryId is not a valid built-in category. See Category.IsBuiltInCategoryValid(BuiltInCategory). |

The given BuiltInCategory value must be valid according to Category.IsBuiltInCategoryValid(BuiltInCategory) .