Distance Method


Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Distance(
	XYZ point
)
Visual Basic
Public Function Distance ( _
	point As XYZ _
) As Double
Visual C++
public:
double Distance(
	XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DBXYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when failed to find the closest point on the curve.

See Also