Distance Method


Curve Distance Method

Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double Distance(
	XYZ point
)

Parameters

point XYZ
The specified point.

Return Value

Double
The real number equal to the shortest distance.
Exceptions
Exception Condition
InvalidOperationException Thrown when failed to find the closest point on the curve.
Remarks
Returns the distance from the closest point on the curve to the specified point.
See Also