Curve Distance Method |
Returns the shortest distance from the specified point to this curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- point XYZ
- The specified point.
Return Value
DoubleThe real number equal to the shortest distance.

Exception | Condition |
---|---|
InvalidOperationException | Thrown when failed to find the closest point on the curve. |

Returns the distance from the closest point on the curve to the specified point.