Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveOrEdgeReference
- Type: Autodesk.Revit.DBReference
Reference to a curve/edge that is part of one profile
- profileIndex
- Type: SystemInt32%
Profile index for output
- curveLoopIndex
- Type: SystemInt32%
Curve loop index for output