GetProfileAndCurveLoopIndexFromReference Method


Form Get Profile And Curve Loop Index From Reference Method

Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void GetProfileAndCurveLoopIndexFromReference(
	Reference curveOrEdgeReference,
	ref int profileIndex,
	ref int curveLoopIndex
)

Parameters

curveOrEdgeReference Reference
Reference to a curve/edge that is part of one profile
profileIndex Int32
Profile index for output
curveLoopIndex Int32
Curve loop index for output
See Also