GetMaterialVolume Method


Gets the volume of the material with the given id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public double GetMaterialVolume(
	ElementId materialId
)
Visual Basic
Public Function GetMaterialVolume ( _
	materialId As ElementId _
) As Double
Visual C++
public:
double GetMaterialVolume(
	ElementId^ materialId
)

Parameters

materialId
Type: Autodesk.Revit.DBElementId
The material id returned from GetMaterialIds(Boolean).

Return Value

The volume of the material for this element. Returns 0.0 if the material is not a part of this element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException materialId is not a valid Element identifier.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also