GetMaterialVolume Method


Element Get Material Volume Method

Gets the volume of the material with the given id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetMaterialVolume(
	ElementId materialId
)

Parameters

materialId ElementId
The material id returned from GetMaterialIds(Boolean) .

Return Value

Double
The volume of the material for this element. Returns 0.0 if the material is not a part of this element.
Exceptions
Exception Condition
ArgumentException materialId is not a valid Element identifier.
ArgumentNullException A non-optional argument was null
See Also