GetTransformForDoorOrWindow Method


Obtains the transform for the door or window instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static Transform GetTransformForDoorOrWindow(
	FamilyInstance familyInstance,
	FamilySymbol familySymbol,
	bool flippedX,
	bool flippedY
)
Visual Basic
Public Shared Function GetTransformForDoorOrWindow ( _
	familyInstance As FamilyInstance, _
	familySymbol As FamilySymbol, _
	flippedX As Boolean, _
	flippedY As Boolean _
) As Transform
Visual C++
public:
static Transform^ GetTransformForDoorOrWindow(
	FamilyInstance^ familyInstance, 
	FamilySymbol^ familySymbol, 
	bool flippedX, 
	bool flippedY
)

Parameters

familyInstance
Type: Autodesk.Revit.DBFamilyInstance
The family instance.
familySymbol
Type: Autodesk.Revit.DBFamilySymbol
The family symbol.
flippedX
Type: SystemBoolean
Is the door or window flipped in X?
flippedY
Type: SystemBoolean
Is the door or window flipped in Y?

Return Value

The transform.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also