GetTransformForDoorOrWindow Method


Exporter IFCUtils Get Transform For Door Or Window Method

Obtains the transform for the door or window instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Transform GetTransformForDoorOrWindow(
	FamilyInstance familyInstance,
	FamilySymbol familySymbol,
	bool flippedX,
	bool flippedY
)

Parameters

familyInstance FamilyInstance
The family instance.
familySymbol FamilySymbol
The family symbol.
flippedX Boolean
Is the door or window flipped in X?
flippedY Boolean
Is the door or window flipped in Y?

Return Value

Transform
The transform.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also