FilterDialog Constructor (Document, ElementId)


Constructs a new instance of the FilterDialog class, while setting the id of the FilterElement to be selected when the dialog is shown.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public FilterDialog(
	Document doc,
	ElementId filterToSelect
)
Visual Basic
Public Sub New ( _
	doc As Document, _
	filterToSelect As ElementId _
)
Visual C++
public:
FilterDialog(
	Document^ doc, 
	ElementId^ filterToSelect
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document that owns the FilterElements displayed and edited in the dialog.
filterToSelect
Type: Autodesk.Revit.DBElementId
The FilterElement to be selected. If InvalidElementId, then the first (if any) available FilterElement will be selected.

Remarks

Show the dialog with the Show() method after setting the desired options.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The supplied ElementId filterToSelect is not of a FilterElement.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also