FilterDialog Constructor (Document, ElementId)


Filter Dialog(Document, Element Id) Constructor

Constructs a new instance of the FilterDialog class, while setting the id of the FilterElement to be selected when the dialog is shown.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FilterDialog(
	Document doc,
	ElementId filterToSelect
)

Parameters

doc Document
The document that owns the FilterElements displayed and edited in the dialog.
filterToSelect ElementId
The FilterElement to be selected. If InvalidElementId, then the first (if any) available FilterElement will be selected.
Exceptions
Exception Condition
ArgumentException The supplied ElementId filterToSelect is not of a FilterElement.
ArgumentNullException A non-optional argument was null
Remarks
Show the dialog with the Show() method after setting the desired options.
See Also