Filter |
Constructs a new instance of the FilterDialog class, while setting the id of the FilterElement to be selected when the dialog is shown.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | The supplied ElementId filterToSelect is not of a FilterElement. |
ArgumentNullException | A non-optional argument was null |

Show the dialog with the Show() method after setting the desired options.