Gets the analysis data on the specified segment.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segmentId
- Type: SystemInt32
The segment id to be retrieved.
Return Value
The calculated data of this segment. Be aware that the segment data may be invalid if the calculation failed.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input must be a valid segment id. |