MEPAnalytical |
Gets the analysis data on the specified segment.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- segmentId Int32
- The segment id to be retrieved.
Return Value
MEPNetworkSegmentDataThe calculated data of this segment. Be aware that the segment data may be invalid if the calculation failed.

Exception | Condition |
---|---|
ArgumentException | The input must be a valid segment id. |