GetSegmentData Method


MEPAnalytical Model Data Get Segment Data Method

Gets the analysis data on the specified segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPNetworkSegmentData GetSegmentData(
	int segmentId
)

Parameters

segmentId Int32
The segment id to be retrieved.

Return Value

MEPNetworkSegmentData
The calculated data of this segment. Be aware that the segment data may be invalid if the calculation failed.
Exceptions
Exception Condition
ArgumentException The input must be a valid segment id.
See Also