NewZone Method


Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Zone NewZone(
	Level level,
	Phase phase
)
Visual Basic
Public Function NewZone ( _
	level As Level, _
	phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone(
	Level^ level, 
	Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DBLevel
The level on which the Zone is to exist.
phase
Type: Autodesk.Revit.DBPhase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise a null reference (Nothing in Visual Basic).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the specified parameter Value is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the electrical system cannot be created by these input phase and level.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the level does not exist in the given document.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the phase does not exist in the given document.

See Also