NewZone Method


Document New Zone Method

Note: This API is now obsolete.

Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a future version of Revit. Please use the GenericZone object instead.")]
public Zone NewZone(
	Level level,
	Phase phase
)

Parameters

level Level
The level on which the Zone is to exist.
phase Phase
The associative phase on which the Zone is to exist.

Return Value

Zone
If successful a new Zone element within the project, otherwise .
Exceptions
Exception Condition
ArgumentNullException Thrown when the specified parameter Value is .
InvalidOperationException Thrown when the electrical system cannot be created by these input phase and level.
ArgumentException Thrown if the level does not exist in the given document.
ArgumentException Thrown if the phase does not exist in the given document.
See Also