NewZone Method


Document New Zone Method

Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Zone NewZone(
	Level level,
	Phase phase
)

Parameters

level Level
The level on which the Zone is to exist.
phase Phase
The associative phase on which the Zone is to exist.

Return Value

Zone
If successful a new Zone element within the project, otherwise .
Exceptions
Exception Condition
ArgumentNullException Thrown when the specified parameter Value is .
InvalidOperationException Thrown when the electrical system cannot be created by these input phase and level.
ArgumentException Thrown if the level does not exist in the given document.
ArgumentException Thrown if the phase does not exist in the given document.
See Also