IsAcceptableToPosition Method


Checks whether a given "to" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool IsAcceptableToPosition(
	XYZ toPosition
)
Visual Basic
Public Function IsAcceptableToPosition ( _
	toPosition As XYZ _
) As Boolean
Visual C++
public:
bool IsAcceptableToPosition(
	XYZ^ toPosition
)

Parameters

toPosition
Type: Autodesk.Revit.DBXYZ

Return Value

True if the input is an acceptable "to" position and False otherwise.

Remarks

The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also