IsAcceptableToPosition Method


Spatial Element From To Calculation Points Is Acceptable To Position Method

Checks whether a given "to" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsAcceptableToPosition(
	XYZ toPosition
)

Parameters

toPosition XYZ

Return Value

Boolean
True if the input is an acceptable "to" position and False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.
See Also