Multiply Operator (UV, Double)


The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV operator *(
	UV left,
	double value
)
Visual Basic
Public Shared Operator * ( _
	left As UV, _
	value As Double _
) As UV
Visual C++
public:
static UV^ operator *(
	UV^ left, 
	double value
)

Parameters

left
Type: Autodesk.Revit.DBUV
The vector to multiply with the value.
value
Type: SystemDouble
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when the specified value is an infinite number.
Autodesk.Revit.ExceptionsArgumentNullException Thrown when left is a null reference (Nothing in Visual Basic).

See Also