Appends an Item to the RebarContainer. Fills its data on base of the Rebar. Will throw exception if given rebar is not shape driven. Will throw exception if given rebar has moved bars in set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rebar
- Type: Autodesk.Revit.DB.StructureRebar
The Rebar.
Return Value
The Rebar Container Item.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The RebarShape of rebar has End Treatments -or- Can't create container from free-form rebar. -or- Can't create container from Rebar with moved bars. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |