AppendItemFromRebar Method


Rebar Container Append Item From Rebar Method

Appends an Item to the RebarContainer. Fills its data on base of the Rebar. Will throw exception if given rebar is not shape driven. Will throw exception if given rebar has moved bars in set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarContainerItem AppendItemFromRebar(
	Rebar rebar
)

Parameters

rebar Rebar
The Rebar.

Return Value

RebarContainerItem
The Rebar Container Item.
Exceptions
Exception Condition
ArgumentException The RebarShape of rebar has End Treatments -or- Can't create container from free-form rebar. -or- Can't create container from Rebar with moved bars.
ArgumentNullException A non-optional argument was null
See Also