AppendItemFromRebar Method


Rebar Container Append Item From Rebar Method

Appends an Item to the RebarContainer. Fills its data on base of the Rebar. Will throw exception if given rebar is not shape driven. Will throw exception if given rebar has moved bars in set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public RebarContainerItem AppendItemFromRebar(
	Rebar rebar
)

Parameters

rebar Rebar
The Rebar.

Return Value

RebarContainerItem
The Rebar Container Item.
Exceptions
Exception Condition
ArgumentException A RebarContainerItem cannot be created from a Free Form Rebar or from a Shape Driven Rebar whose Rebar Shape has End Treatments or Cranks or terminations' rotation angles are different than 0. -or- Can't create container from Rebar with moved bars.
ArgumentNullException A non-optional argument was null
See Also