Autodesk.Revit.DB.Events Namespace


 

Classes

  ClassDescription
Public classApplicationInitializedEventArgs
The event arguments used by the ApplicationLaunched event.
Public classCreateRelatedFileProgressChangedEventArgs
The event arguments used during creating related file phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] in model open operation.
Public classDataTransferProgressChangedEventArgs
The event arguments used during the data transferring phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged].
Public classDocumentChangedEventArgs
The event arguments used by the DocumentChanged event.
Public classDocumentClosedEventArgs
The event arguments used by the DocumentClosed event.
Public classDocumentClosingEventArgs
The event arguments used by the DocumentClosing event.
Public classDocumentCreatedEventArgs
The event arguments used by the DocumentCreated event.
Public classDocumentCreatingEventArgs
The event arguments used by the DocumentCreating event.
Public classDocumentOpenedEventArgs
The event arguments used by the DocumentOpened event.
Public classDocumentOpeningEventArgs
The event arguments used by the DocumentOpening event.
Public classDocumentPrintedEventArgs
The event arguments used by the DocumentPrinted event.
Public classDocumentPrintingEventArgs
The event arguments used by the DocumentPrinting event.
Public classDocumentReloadedLatestEventArgs
The event arguments used by the DocumentReloadedLatestEvent event. This event will be raised when executing pull a latest changes from a central model.
Public classDocumentReloadingLatestEventArgs
The event arguments used by the DocumentReloadingLatest event.
Public classDocumentReloadLatestProgressChangedEventArgs
The event arguments used during the reload latest phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged].
Public classDocumentSavedAsEventArgs
The event arguments used by the DocumentSavedAs event.
Public classDocumentSavedEventArgs
The event arguments used by the DocumentSaved event.
Public classDocumentSaveToCentralProgressChangedEventArgs
The event arguments used during the save to central phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged].
Public classDocumentSaveToLocalProgressChangedEventArgs
The event arguments used during the save to local phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged].
Public classDocumentSavingAsEventArgs
The event arguments used by the DocumentSavingAs event.
Public classDocumentSavingEventArgs
The event arguments used by the DocumentSaving event.
Public classDocumentSynchronizedWithCentralEventArgs
The event arguments used by the DocumentSynchronizedWithCentralEventArgs event.
Public classDocumentSynchronizingWithCentralEventArgs
The event arguments used by the DocumentSynchronizingWithCentralEventArgs event.
Public classDocumentWorksharingEnabledEventArgs
The event arguments used by the DocumentWorksharingEnabled event.
Public classElementTypeDuplicatedEventArgs
The event arguments used by the ElementTypeDuplicated event.
Public classElementTypeDuplicatingEventArgs
The event arguments used by the ElementTypeDuplicating event.
Public classExternalDataInstanceAddedIntoDocumentEventArgs
The event arguments used by the ExternalDataInstanceAddedInto event.
Public classExternalDataInstanceAddingIntoDocumentEventArgs
The event arguments used by the ExternalDataInstanceAddingInto event.
Public classExternalDataInstanceRemovedFromDocumentEventArgs
The event arguments used by the ExternalDataInstanceRemovedFrom event.
Public classExternalDataInstanceRemovingFromDocumentEventArgs
The event arguments used by the ExternalDataInstanceRemovingFrom event.
Public classExternalDataTypeServerFailureResolutionExecutingEventArgs
The event arguments used by the ExternalDataTypeServerFailureResolutionExecuting event.
Public classFailuresProcessingEventArgs
The event arguments used by the FailuresProcessing event.
Public classFamilyLoadedIntoDocumentEventArgs
The event arguments used by the FamilyLoadedInto event.
Public classFamilyLoadingIntoDocumentEventArgs
The event arguments used by the FamilyLoadingInto event.
Public classFileExportedEventArgs
The event arguments used by the FileExported event.
Public classFileExportingEventArgs
The event arguments used by the FileExporting event.
Public classFileImportedEventArgs
The event arguments used by the FileImported event.
Public classFileImportingEventArgs
The event arguments used by the FileImporting event.
Public classLinkedResourceOpenedEventArgs
The event arguments used by [!:Autodesk::Revit::ApplicationServices::Application::LinkedResourceOpened].
Public classLinkedResourceOpeningEventArgs
The event arguments used by [!:Autodesk::Revit::ApplicationServices::Application::LinkedResourceOpening].
Public classPostDocEventArgs
The class is used as base class for arguments of any post-event that is associated to a particular Document.
Public classPostEventArgs
The class is used as a base class for arguments of any post-event.
Public classPreDocEventArgs
The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.
Public classPreEventArgs
The class is used as a base class for the arguments for any pre-event.
Public classProgressChangedEventArgs
The event arguments used by the ProgressChanged event.
Public classProjectBrowserDataChangedEventArgs
The event arguments used by the ProjectBrowserDataChanged event.
Public classRevitAPIEventArgs
The class is used as base class for all event argument classes.
Public classRevitAPIPostDocEventArgs
The base class used for post events where the arguments must supply access to the document.
Public classRevitAPIPostEventArgs
The class is used as a base class for arguments of any post-event.
Public classRevitAPIPreDocEventArgs
The base class used for pre events where the arguments must supply access to the document.
Public classRevitAPIPreEventArgs
The class is used as a base class for the arguments for any pre-event.
Public classRevitAPISingleEventArgs
The class is used as a base class for arguments of any single-event.
Public classRevitEventArgs
The class is used as base class for all event argument classes.
Public classViewExportedEventArgs
The event arguments used by the ViewExported event.
Public classViewExportingEventArgs
The event arguments used by the ViewExporting event.
Public classViewPrintedEventArgs
The event arguments used by the ViewPrinted event.
Public classViewPrintingEventArgs
The event arguments used by the ViewPrinting event.
Public classViewsExportedByContextEventArgs
The event arguments used by the ViewsExportedByContext event.
Public classViewsExportingByContextEventArgs
The event arguments used by the ViewsExportingByContext event.
Public classWorksharedOperationProgressChangedEventArgs
The event arguments used by the WorksharedOperationProgressChanged event, this event will be raised when executing following workshared operations.

Enumerations

  EnumerationDescription
Public enumerationDataTransferMode
Describes the data transfer mode.
Public enumerationEventStatus
Describes the status of an action which triggered a post event.
Public enumerationProgressStage
The associated action of a ProgressChanged event
Public enumerationRevitAPIEventStatus
Describes the status of an action which triggered a post event.
Public enumerationUndoOperation
The operation associated with DocumentChanged event