GetSubelementOnLevel Method


Gets the subelement on given level.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public Subelement GetSubelementOnLevel(
	ElementId levelId
)
Visual Basic
Public Function GetSubelementOnLevel ( _
	levelId As ElementId _
) As Subelement
Visual C++
public:
Subelement^ GetSubelementOnLevel(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DBElementId
The id of the level the railing subelement is placed on.

Return Value

The subelement in given level. a null reference (Nothing in Visual Basic) will be returned if railing has no subelements on given level.

Remarks

The method is valid only for railings hosted by stairs in MultistoryStairs. Input level should be a level of the railing stairs. See getStairsPlacementLevels method of MultistoryStairs.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The railing is not hosted by stairs in MultistoryStairs.

See Also