Railing Get |
Gets the subelement on given level.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- levelId ElementId
- The id of the level the railing subelement is placed on.
Return Value
SubelementThe subelement in given level. will be returned if railing has no subelements on given level.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The railing is not hosted by stairs in MultistoryStairs . |

The method is valid only for railings hosted by stairs in MultistoryStairs . Input level should be a level of the railing stairs. See getStairsPlacementLevels method of MultistoryStairs .